Nerdy Drunk

Drunk on technology

User Tools

Site Tools


cisco:ios-ospf

Cisco IOS OSPF

Configurations

Router 192.168.1.1

!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.1 0.0.0.0 area 0
!
ip classless
!

Router 192.168.1.2

!
interface Loopback0
 ip address 192.168.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.0.1 255.255.255.252
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.2 0.0.0.0 area 0
 network 172.16.0.0 0.0.0.7 area 0
!
ip classless
!

Router 192.168.1.3

!
interface Loopback0
 ip address 192.168.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.0.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.0.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 network 172.16.0.0 0.0.0.7 area 0
 network 192.168.1.3 0.0.0.0 area 0
 network 10.1.0.0 0.0.0.255 area 1
!
ip classless
!

Router 192.168.1.4

!
interface Loopback0
 ip address 192.168.1.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.2.0.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.4 0.0.0.0 area 0
 network 10.2.0.0 0.0.0.255 area 2
!
ip classless
!

Router 192.168.1.5

!
interface Loopback0
 ip address 192.168.1.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 10.2.0.0 0.0.0.255 area 2
 network 192.168.1.5 0.0.0.0 area 2
!
ip classless
!

Routing Tables

Router 192.168.1.1

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
O IA    10.1.0.0 [110/3] via 10.0.0.2, 00:21:22, FastEthernet0/0
O IA    10.2.0.0 [110/2] via 10.0.0.3, 00:21:22, FastEthernet0/0
     172.16.0.0/30 is subnetted, 1 subnets
O       172.16.0.0 [110/2] via 10.0.0.2, 00:21:22, FastEthernet0/0
     192.168.1.0/32 is subnetted, 5 subnets
C       192.168.1.1 is directly connected, Loopback0
O       192.168.1.2 [110/2] via 10.0.0.2, 00:21:22, FastEthernet0/0
O       192.168.1.3 [110/3] via 10.0.0.2, 00:21:22, FastEthernet0/0
O       192.168.1.4 [110/2] via 10.0.0.3, 00:21:22, FastEthernet0/0
O IA    192.168.1.5 [110/3] via 10.0.0.3, 00:21:22, FastEthernet0/0
Router#

Router 192.168.1.2

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
O IA    10.1.0.0 [110/2] via 172.16.0.2, 00:20:47, FastEthernet0/1
O IA    10.2.0.0 [110/2] via 10.0.0.3, 00:20:37, FastEthernet0/0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/1
     192.168.1.0/32 is subnetted, 5 subnets
O       192.168.1.1 [110/2] via 10.0.0.1, 00:20:47, FastEthernet0/0
C       192.168.1.2 is directly connected, Loopback0
O       192.168.1.3 [110/2] via 172.16.0.2, 00:20:47, FastEthernet0/1
O       192.168.1.4 [110/2] via 10.0.0.3, 00:20:47, FastEthernet0/0
O IA    192.168.1.5 [110/3] via 10.0.0.3, 00:20:37, FastEthernet0/0
Router#

Router 192.168.1.3

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
O       10.0.0.0 [110/2] via 172.16.0.1, 00:20:28, FastEthernet0/0
C       10.1.0.0 is directly connected, FastEthernet0/1
O IA    10.2.0.0 [110/3] via 172.16.0.1, 00:20:08, FastEthernet0/0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
     192.168.1.0/32 is subnetted, 5 subnets
O       192.168.1.1 [110/3] via 172.16.0.1, 00:20:18, FastEthernet0/0
O       192.168.1.2 [110/2] via 172.16.0.1, 00:20:28, FastEthernet0/0
C       192.168.1.3 is directly connected, Loopback0
O       192.168.1.4 [110/3] via 172.16.0.1, 00:20:28, FastEthernet0/0
O IA    192.168.1.5 [110/4] via 172.16.0.1, 00:20:08, FastEthernet0/0
Router#

Router 192.168.1.4

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
O IA    10.1.0.0 [110/3] via 10.0.0.2, 00:19:55, FastEthernet0/0
C       10.2.0.0 is directly connected, FastEthernet0/1
     172.16.0.0/30 is subnetted, 1 subnets
O       172.16.0.0 [110/2] via 10.0.0.2, 00:19:55, FastEthernet0/0
     192.168.1.0/32 is subnetted, 5 subnets
O       192.168.1.1 [110/2] via 10.0.0.1, 00:19:55, FastEthernet0/0
O       192.168.1.2 [110/2] via 10.0.0.2, 00:19:55, FastEthernet0/0
O       192.168.1.3 [110/3] via 10.0.0.2, 00:19:55, FastEthernet0/0
C       192.168.1.4 is directly connected, Loopback0
O       192.168.1.5 [110/2] via 10.2.0.2, 00:20:10, FastEthernet0/1
Router#

Router 192.168.1.5

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
O IA    10.0.0.0 [110/2] via 10.2.0.1, 00:18:08, FastEthernet0/0
O IA    10.1.0.0 [110/4] via 10.2.0.1, 00:18:08, FastEthernet0/0
C       10.2.0.0 is directly connected, FastEthernet0/0
     172.16.0.0/30 is subnetted, 1 subnets
O IA    172.16.0.0 [110/3] via 10.2.0.1, 00:18:08, FastEthernet0/0
     192.168.1.0/32 is subnetted, 5 subnets
O IA    192.168.1.1 [110/3] via 10.2.0.1, 00:18:08, FastEthernet0/0
O IA    192.168.1.2 [110/3] via 10.2.0.1, 00:18:08, FastEthernet0/0
O IA    192.168.1.3 [110/4] via 10.2.0.1, 00:18:08, FastEthernet0/0
O IA    192.168.1.4 [110/2] via 10.2.0.1, 00:18:08, FastEthernet0/0
C       192.168.1.5 is directly connected, Loopback0
Router#
cisco/ios-ospf.txt · Last modified: 2022/07/21 10:41 by 127.0.0.1